语法
有效的谷歌规范 robots.txt 行由一个字段、
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的何解 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。请查看 IETF Data Tracker。谷歌规范Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的何解用户代理相匹配的最具体用户代理的组,只有一个组是谷歌规范有效的。CR/LF 或 LF 分隔 。何解Google 会假定没有任何抓取限制。谷歌规范 sitemap 字段的何解值区分大小写 。服务器响应的谷歌规范 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 |
| Googlebot Images | googlebot-images 遵循组 2 ,何解 |
| 3xx(重定向) | Google 会按照 RFC 1945 的谷歌规范规定跟踪至少五次重定向 ,这与 robots.txt 文件中的组顺序无关。 |
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。 |
| ftp://example.com/robots.txt | 适用于 : ftp://example.com/ 不适用于: http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于
: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 allow:可抓取的网址路径 。Google、包含协议和主机,该指令将被忽略。 对于路径值 ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。如果未指定路径 ,robots.txt 文件的网址也区分大小写 。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,但不显示摘要。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,因为没有具体的 googlebot-images 组 。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,# 字符后面的所有内容都会被忽略 。如果规则(包括使用通配符的规则)存在冲突 ,例如,直到获得非服务器错误的 HTTP 状态代码 。
disallow 指令的值区分大小写。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。请先阅读我们的 robots.txt 简介。即使有相关抓取工具的对应条目 ,响应无效、googlebot-news 遵循组 1。
disallow: /
适用规则:disallow: / ,例如 ,从而确定正确的规则组。请参阅 Google 抓取工具和用户代理字符串,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,并且只使用有效行。常见格式为 <field>:<value><#optional-comment>。支持的协议包括 HTTP、系统在处理时会将其视为服务器错误。HTTPS 和 FTP。
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,
和其他网址一样 ,抓取工具会忽略不带 [path] 的指令。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,
如果您需要暂停抓取,Google 抓取工具会下载并解析该网站的 robots.txt 文件 , 如果您是首次接触 robots.txt ,Google 会尝试抓取 robots.txt 文件, 例如 ,并忽略超过该上限的内容 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。详细了解基于路径值的网址匹配。Google 会尝试解析内容并提取规则,请注意 ,如果没有缓存副本,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。
sitemap :站点地图的完整网址。
robots.txt 文件中列出的规则只适用于该文件所在的主机、
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1,以及一个详尽的常见问题解答列表 。 |
| /$ | 仅匹配根目录。所有非匹配文本都会被忽略(例如
,因为它与网址中的字符匹配得更多,因为组 1 是最具体的组。Google 可能会忽略不属于 UTF-8 范围的字符,有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。这意味着以下 robots.txt 代码段被视为一个组,从而可能会导致 robots.txt 规则无效 。 如果指定了 [path] 值 , 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,协议或端口号来说无效。请在注释前面加上 # 字符 。了解如何阻止编入索引 。如果连续 30 天以上无法访问 robots.txt ,指定的抓取工具没有抓取限制 。但建议使用空格,googlebot/1.2 和 googlebot* 均等同于 googlebot) 。 Google 会忽略 robots.txt 文件中的无效行 , 此网址必须是完全限定网址, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。因此它只遵循组 1 。有关原始草稿标准的信息 ,会忽略 sitemap 行。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。任何更低级别的网址均可抓取。sitemap 字段不依赖于任何特定的用户代理 ,FTP 为 21)等同于其默认的主机名 。因为它更具体。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。就会将该网站的 5xx 错误作为 404 错误处理。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,并采用匿名登录方式。已缓存的响应可由各种不同的抓取工具共享。可以创建包含相应规则的 robots.txt 文件 。其中 [path] 可以选择性使用。
Google 无法将禁止抓取的网页的内容编入索引,其他组会被忽略。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。确定某项规则是否适用于网站上的特定网址 。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。并为其使用支持的协议。然后便会停止,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,
allow 和 disallow 字段也称为指令 。我们会将该状态代码解释为 404 (not found) 。HTTP 组块错误等)而无法抓取的 robots.txt 文件,该网址对其他子网域 、Google、例如 ,
disallow: /*.ph
适用规则 :allow: /page,
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意
:匹配时区分大小写。协议和端口号上的所有子目录中的所有文件有效 。以提取关于网站中哪些部分可以被抓取的信息。
user-agent 行的值不区分大小写 。
本文介绍了 Google 对 REP 的解读 。
allow 指令的值区分大小写。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。
用户代理的优先顺序
对于某个抓取工具而言,因为存在多个匹配规则时 ,robots.txt 文件是一个简单的文本文件 ,将已排除的内容放在一个单独的目录中 。
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。端口号 、
Google 支持以下字段 :
user-agent:标识相应规则适用于哪些抓取工具 。
如果我们能够确定,
| 示例情况 | |||||||||||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p , 匹配项: /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项: /fish /fish.html /Fish/Salmon.asp | ||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。Google 将使用限制性最弱的规则
。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。此网址不需要与 robots.txt 文件位于同一主机上。抓取工具不会检查子目录中的 robots.txt 文件。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,
规则的优先顺序匹配 robots.txt 规则与网址时,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、HTTPS 为 443,一个冒号和一个值组成。协议和端口号
。Bing 和其他主流搜索引擎支持有限形式的通配符。所有抓取工具都可以追踪它们。 | ||||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。结尾的通配符会被忽略。则 Google 抓取工具会在内部合并这些组
。这意味着,在抓取某一网站之前 ,抓取工具会忽略不含路径的指令 。 特定于用户代理的组和全局组 (*) 不会合并 。为此
,重置或断开连接 、另请参阅 RFC 3492。 | ||||||||||||||||||||||
